Overview
This article provides instructions on steps to take when you attempt to reset your password using the "forgot password, or need help logging in?" link and receiving the "An error occurred while processing your request. Please try again" error message.
Diagnosis
When attempting to reset your password using the "Forgot password, or need help logging in?" link (below on the left) and you receive the error (below on the right) "An error occurred while processing your request. Please try again".
Solution
Usually when this error occurs, the email address that is being submitted is not listed under an account in the GFI Accounts Portal. After ensuring the spelling is correct, if you know who is the primary user or someone in your company who has access to your company's account in the GFI Accounts Portal, have them verify you are listed there as an account user.
If not listed as an account user, the primary user can add a new user to add you as an account user.
If you are listed as an account user, using the editing a user article, you can verify the username used to log in.
If you are unable to log in after attempting the above, please open a support ticket at https://support.gfi.com with the email address being used and your customer ID.