Overview
This article addresses an issue where GFI WebMonitor only applies the default policy.
Root Cause
The reason for this behavior is that GFI WebMonitor is unable to resolve the user groups correctly, which could be due to either of the following reasons:
- Authentication is not enabled.
- GFI WebMonitor Core account not using a Domain Administrator Account.
- Pre-W2K name and actual name group mismatch.
Resolution
- Make sure that authentication is enabled under Settings > Proxy Settings for Standalone Proxy or in Microsoft ISA/TMG. If this is in place, you should see usernames displayed under Dashboard > Activity.
- Make sure the GFI WebMonitor Core service account is using a Domain Administrator Account so that it can resolve groups in the Active Directory.
- If assigning policies to groups, check that the pre-W2K name and the actual name group is the same. If it is not, change the group name to match the pre-w2K or vice-versa.