Answer
PROBLEM
Real time data cannot be seen in the dashboard.
ENVIRONMENT
- GFI WebMonitor
- All supported environments
SOLUTION
This will happen when GFI WebMonitor's backend database is full and cannot hold any more new data. The maximum size of this database will vary based upon what type of database you are using:
- Microsoft SQL Server Express 2008 and below - 4GB
- Microsoft SQL Server Express 2008R2 and higher - 10 GB
- Microsoft SQL Server (Not Express) - Unlimited
- Microsoft SQL Server MSFW embedded (installed with Microsoft ISA/TMG) - 2GB
If the database has reached the maximum limit, please do the following:
GFI WebMonitor 2013
- In GFI WebMonitor open Settings > Database
- Enter a new database name (that does not exist on the Microsoft SQL Server instance) in the Database box and click Save. A new database will be created.
GFI WebMonitor 2015 and later
- Open the GFI WebMonitor Management Console
- Select the "Settings" drop down in the top right (gear icon)
- Under "Core Settings" select "Database"
- Navigate to the "SQL Server" tab
- Enter a new database name (that does not exist on the Microsoft SQL Server instance) in the Database box and click Save. A new database will be created.
- Click "Save" to apply the changes
CAUSE
The Microsoft SQL database is full and no more data can be inserted into it.