Answer
PROBLEM
When trying to open the GFI WebMonitor application interface it displays an error or some of the pages display errors such as:
- Action Cancelled
- Could not access this page
- Script errors on this page
- Failed to get status data from component
- WebMonitor Data is not accessible
ENVIRONMENT
- GFI WebMonitor
- All Supported Environments
SOLUTION
- Make sure the following services are running:
- GFI WebMonitor service
- GFI WebMonitor Core service
- GFI Proxy service (stand-alone proxy version only)
- Microsoft Firewall service (for the ISA/TMG version only)
- For Windows domains:
- Make sure the computer GFI WebMonitor is installed on is a member of the domain.
- Make sure the user account the GFI WebMonitor Service is using is a Domain Administrator account
- Make sure the following processes are running:
- WebMonSrv.exe
- WebMonWeb.exe
- WMonProc.exe
- WebMonAV*Scan.exe
- ML.Svc.Attendant.exe
- GFIProxy.exe (stand-alone proxy version only)
- Windows Firewall (local firewall - not the ISA/TMG/Microsoft firewall): Do one of the following:
-
Disable it
-
Make an exclusion for TCP ports 1007, 8080 (or whatever port you configure for your proxy port), and 80
- Add the following entries to the "Safe Sites" in your Internet Explorer Browser:
- http://monitor.isa
- http://127.0.0.1:1007
- http://1.1.1.1
CAUSE
The GFI WebMonitor's user interface is a web page and the above settings are required to make it work correctly