Overview
When accessing a website for the first time, users are blocked by WebMonitor. Once the page is refreshed, it loads successfully. Similarly, the main URL accessed might load. However, parts of the website, like images and scripts, do not load.
When accessing an HTTPs website, the user receives the below browser error:
Page cannot be displayed
Root Cause
This issue appears when the Web Filtering policy is configured to block the Unavailable category, and WebMonitor cannot categorize websites fast enough; this may happen in environments dealing with a heavy load or slower server and Internet performance. In such cases, by default, WebMonitor does not wait for the URL to be categorized and continues processing the request to avoid delaying the response to the client.
Resolution
- Open the Registry Editor by navigating to Start > Run; type
regedit.exe
and press Enter. - Navigate to the following key:
- x86: HKEY_LOCAL_MACHINE\SOFTWARE\GFI\WebMonitor
- x64: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\GFI\WebMonitor
- Create a new DWORD value called
OnlineLookupTimeout
. - Specify, in seconds, a timeout for how long should WebMonitor wait for a website to be categorized, e.g., 5, 10, 15, etc.
- Restart the GFI Proxy service (Standalone version) or the Microsoft Firewall service (ISA/TMG plugin).