Overview
Upon opening the GFI WebMonitor User Interface https://127.0.0.1:1007/Dashboard
, the following error is received:
Communication Error: Failed to connect the GFI WebMonitor web filter. Please check that the GFI Proxy service is running.
This article provides a solution based on the root cause found that's causing users to not be able to access the GFI WebMonitor UI.
Information
Environment
GFI WebMonitor
Root Cause Analysis
Diagnosis
The GFI WebMonitor plugin is not functioning.
Solution
Standalone Proxy Version
- Check if the GFI Proxy service or
GFIProxy.exe
process is running.- If it is not running, start it under Services:
- Click Start > Run and type
services.msc
- Click Start > Run and type
- If it is not running, start it under Services:
Microsoft TMG Version
- Check if the GFI WebMonitor Webfilter is listed in the TMG (Threat Management Gateway) Management Console under the following node: System > Webfilters
- If the GFI WebMonitor Webfilter is listed, make sure it is Enabled.
- If the GFI WebMonitor Webfilter is not listed, follow the steps below:
- Stop the GFI WebMonitor services.
- Make sure the
WebMonPlg.dll
is listed in the TMG server's installation directory. - Open a command prompt and change the directory to the TMG server's installation directory.
- Run the following command:
regsvr32 webmonplg.dll
- Close and reopen the TMG Management Console.
- Check if the GFI WebMonitor Webfilter is now listed and enabled.
- Restart the GFI WebMonitor services.
NOTE: On the Microsoft TMG array, also check the Webfilter and, if necessary, perform the above steps on each node in the array.
Confirmation
You should be able to successfully open the GFI WebMonitor UI.