Overview
This article addresses an issue where the WebGrade, anti-virus, and anti-phishing updates fail.
Root Cause
GFI WebMonitor is hardcoded to use port 127.0.0.1:8080 for these connections. If Microsoft TMG or the GFI WebMonitor Standalone Proxy version is configured to use a different proxy port, this may cause updates to fail. Refer to Configuring Webmonitor's Proxy Settings to Update Virus Definition Files to set it to use the correct port.
When the GFI WebMonitor service contacts the update site, GFI Servers check the license key. If it is listed as 'Evaluation' or an invalid key, it does not serve up the necessary files for download.
Resolution
- Make sure that the license key in use is a valid license key. If you are in evaluation, you must not use 'Evaluation' as the key; you must have a valid evaluation key sent to you by email. If you have not received one, check your spam or junk folder. If you cannot find the email, go to our website and fill out the download form again.
- Make sure that *.gfi.com and gfi-downloader-137146314.us-east-1.elb.amazonaws.com are listed in the Whitelist.
- Check and determine if connections to https://webmonupdate.gfi.com or http://cdnupdate.gfi.com are present in the GFI WebMonitor Web Interface under the Active or Past Connections nodes. If they are not visible, refer to Configuring Webmonitor's Proxy Settings to Update Virus Definition Files to apply them.
Note: Use the article above even if the web proxy port is configured to use the default port 8080.
To determine what port is configured for the web proxy, check in the following locations:
- GFI WebMonitor Proxy Edition: under Configuration > Proxy Settings
- TMG Server: in the Web Proxy tab, under Networking > Internal Network (properties).